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Customize the Ribbon in
AutoCAD 2009

This tutorial outlines how to customize the ribbon in AutoCAD. The ribbon is a palette that
displays task-based buttons and controls that are relevant to the current workspace. It
eliminates the need to display multiple toolbars, reducing clutter in the application and
maximizing the drawing area available.

Audience: Users new to the AutoCAD 2009 user interface (UI)

Prerequisites: None

Time to complete: 30 minutes

Usage Scenario
John Cad and Partners have entered into an agreement with Raffles Junior
College to design the layout of the school’s new campus. They will be providing
a set of 2D drawings for the proposed design.

Problem: John Cad and Partners need to present 2D drawings of the school’s
new campus. They want to use a single interface for all the operations they will
need.
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Solution: By customizing the ribbon, John Cad and Partners can:

■ Display and access commonly used commands and controls

■ Maximize the available drawing area

Features covered in this tutorial:

1 Organize commonly used commands on the ribbon

2 Use existing toolbars to customize ribbon panels

3 Add, reposition, and remove commands from the ribbon

4 Create and display a ribbon tab on the ribbon

In This Tutorial

■ Lesson 1: Display the Ribbon on page 2

■ Lesson 2: Create a Ribbon Panel on page 5

■ Lesson 3: Copy an Existing Toolbar to a Ribbon Panel on page 13

■ Lesson 4: Add Ribbon Panel Controls on page 15

■ Lesson 5: Create a Ribbon Tab on page 17

■ Lesson 6: Display and Reposition a Ribbon Tab on page 18

Lesson 1: Display the Ribbon

The ribbon in 2D Drafting & Annotation workspace
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In this lesson, you will help John Cad and Partners to:

■ Display the ribbon in the 2D Drafting & Workspace

■ Organize the ribbon to maximize the available drawing area

The ribbon is displayed by default when you create or open a drawing using
either the 2D Drafting & Annotation or 3D Modeling workspaces, with
commands and controls relevant to the current workspace.

To display the ribbon

1 Click Start menu (Windows) ➤ Programs ➤ Autodesk ➤ AutoCAD
2009 ➤ AutoCAD 2009.

2 Click  ➤ Tools menu ➤ Workspaces ➤ 2D Drafting & Annotation.

NOTE You can also click Workspace Switching on the status bar to switch
workspaces.

The ribbon displays and contains commands and controls relevant to 2D
drafting and annotation.

To minimize the ribbon

1 Click the ribbon minimize button to the right of the ribbon tabs.

NOTE Minimize behavior is available only for the horizontal ribbon.

2 The minimize behavior will cycle through the following minimize options:

■ Minimize to Panels: Minimizes the ribbon so that only tab and panel
titles are displayed

■ Minimize to Tabs: Minimizes the ribbon so that only tab titles are
displayed
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■ Show Full Ribbon: Displays tabs and full panels, including controls

To show or hide ribbon panel titles

■ Right-click a ribbon panel and click Show Panel Titles.

To display or hide a ribbon panel

1 Ensure that the full ribbon and panel titles are shown.

2 Click the Home tab.

NOTE You can only display or hide ribbon panels for the active ribbon tab.
To display or hide panels on other tabs, you must switch to the relevant tab
first.

3 Right-click a ribbon panel.

4 Click Panels ➤ Annotation.
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NOTE To redisplay the Annotation panel on the ribbon, click Annotation in
the Panels list.

The ribbon before and after Annotation panel was hidden

Summary: In this lesson, you learned how to:

■ Minimize the ribbon

■ Show or hide the text labels of the ribbon panels

■ Display or hide a ribbon panel

Next Lesson: Lesson 2: Create a Ribbon Panel on page 5

Lesson 2: Create a Ribbon Panel

The Layers panel expanded and pinned on the ribbon

In this lesson, you will help John Cad and Partners to create a ribbon panel.
The panel will contain the commands frequently used for 2D drafting and
annotation.

By customizing ribbon panels, you can organize the commands that you use
frequently.
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To create a ribbon panel

1 On the ribbon, click the Tools tab ➤ Customization panel ➤ User

Interface. 

2 In the Customize User Interface (CUI) Editor, Customize tab, in the
Customizations In All CUI Files pane, right-click Ribbon Panels.

3 Click New Panel. A new panel (named Panel1) is displayed at the bottom
of the Ribbon Panels tree.

4 Right-click Panel1 and select Rename.

5 Enter My Tools as the new name.
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To update the properties of the new ribbon panel

6 In the tree view, select My Tools. In the Properties pane, do the following:

■ In the Display Text box, enter My Tools as the title for the ribbon
panel.

■ In the Description box, enter Tools for campus for the ribbon panel.

7 Click Apply.

To add a row to a ribbon panel

1 Right-click My Tools and click New Row.

To add a command to a ribbon panel

1 In the Command List box, enter plot.
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2 Drag the Plot command from the Command List pane to the Row 1 item
on the My Tools panel. Use the visual indicator bar to specify the position
of the command.

TIP You can also copy and paste a command from the Command List to a
row on a ribbon panel.
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To show the label and set the orientation of a command or flyout on a ribbon
panel

3 Under the Row 1 item on the My Tools panel, select the Plot command.

4 In the Properties pane, do the following:

■ In the Orientation box, click the down arrow and select Vertical. This
controls how the command looks when its label is shown.

■ In the Size box, click the down arrow and select Standard. This controls
the size of the button on the ribbon.

■ In the Show Label box, click the down arrow and select Yes. This
displays the label for the command.

5 Click Apply.

Preview of the My Tools panel in the Panel Preview pane
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To create a flyout

1 Right-click Row 1 and click New Flyout.

A new flyout (named New Flyout) is created in the last position of the
row.

2 Right-click New Flyout and click Rename.

3 Enter Arc Commands.

To add commands to a flyout

4 In the Command List box, enter arc.

5 In the Command List pane, drag the following commands to the new
flyout in the Customizations In All CUI Files pane:

■ Arc, 3 Points

■ Arc, Center, Start, Angle

■ Arc, Center, Start, End
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TIP To select multiple commands, press and hold CTRL and select the
commands. You can also copy and paste commands from the Command List
pane to a flyout.

6 Select Arc Commands. In the Properties pane, do the following:

■ In the Button Style box, click the down arrow and select Execute. This
option executes the current flyout item, instead of expands the flyout.

■ In the Flyout Style box, click the down arrow and select Icons. This
option displays only icons, instead of text, for the flyout.
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7 Click OK.

Preview of the My Tools panel in the Panel Preview pane

NOTE My Tools panel is not displayed on the ribbon. The last lesson in this
tutorial covers how to display this panel on the ribbon.

Summary: In this lesson, you learned how to:

■ Create a ribbon panel

■ Add a row to a ribbon panel

■ Add commands to a ribbon panel

■ Add a flyout to a ribbon panel

■ Add commands to a flyout

Next Lesson: Lesson 3: Copy an Existing Toolbar to a Ribbon Panel on page
13
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Lesson 3: Copy an Existing Toolbar to a
Ribbon Panel

Convert the Dimension toolbar into a ribbon panel

In this lesson, you will help John Cad and Partners copy an existing toolbar
to a ribbon panel.

You can convert a toolbar to a ribbon panel displayed on the ribbon.

To copy an existing toolbar to ribbon panels

1 On the ribbon, click the Tools tab ➤ Customization panel ➤ User

Interface. 

2 In the CUI Editor, Customize tab, in the Customizations In All CUI Files
pane, click the plus sign (+) next to Toolbars.

3 Right-click the Find Text toolbar and click Copy to Ribbon Panels.
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4 In the Convert to Ribbon Panel dialog box, click Yes.

The toolbar is converted to a ribbon panel and is displayed at the bottom
of the Ribbon Panels tree.

5 Click OK.

Summary: In this lesson, you learned how to copy an existing toolbar to a
ribbon panel.

Next Lesson: Lesson 4: Add Ribbon Panel Controls on page 15
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Lesson 4:Add Ribbon Panel Controls

In this lesson, you will help John Cad and Partners to add ribbon panel
controls.

Ribbon panel controls include drop-down lists, sliders, text boxes, and other
panel-specific controls. For example, the Layers panel contains controls for
changing the layers in a drawing. In the CUI Editor, you can add, remove,
and relocate controls on panels.

To add a control to a ribbon panel

1 On the ribbon, click the Tools tab ➤ Customization panel ➤ User

Interface. 

2 In the CUI Editor, Customize tab, in the Customizations In All CUI Files
pane, next to Ribbon Panels, click the plus sign (+).

3 Next to My Tools, click the plus sign (+).

4 In the Command List pane, in the Categories list, click Control Elements.
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The Command List pane displays control elements only.

5 In the Command List box, enter Layer.

6 Under the My Tools panel, drag the Layer control from the Command
List pane to the Row 2 item. To specify the position of the control, use
the visual indicator bar.

TIP You can also copy and paste a control from the Command List to a row
on a ribbon panel.

7 Click OK.

Preview of the My Tools panel in the Panel Preview pane
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Summary: In this lesson, you learned how to add a control to a ribbon panel.

Next Lesson: Lesson 5: Create a Ribbon Tab on page 17

Lesson 5: Create a Ribbon Tab

The Blocks & References tab with associated panels

In this lesson, you will help John Cad and Partners to create a ribbon tab and
add panels to it.

Ribbon tabs are used to control the display and order of panels on the ribbon.
You add ribbon tabs to a workspace to display task-specific tabs in that
workspace.

To create a ribbon tab

1 On the ribbon, click the Tools tab ➤ Customization panel ➤ User

Interface. 

2 In the CUI Editor, Customize tab, in the Customizations In All CUI Files
pane, right-click Ribbon Tabs.

3 Click New Tab. A new tab (named New Tab) is displayed at the end of
the Ribbon Tabs tree.

4 Right-click New Tab and click Rename. Enter My Utilities as the new name
for the ribbon tab.

5 Click Apply.
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To add a ribbon panel to a ribbon tab

6 In the Customizations In All CUI Files pane, click the plus sign (+) next
to Ribbon Panels to expand it.

7 Drag My Tools and Find Text from the Ribbon Panels node to the My
Utilities ribbon tab. To specify the position of the ribbon panel on the
ribbon tab, use the visual indicator.

TIP You can also copy and paste a ribbon panel from the Ribbon Panels node
to a ribbon tab.

8 Click OK.

Summary: In this lesson, you learned how to create a ribbon tab and add
ribbon panels to a ribbon tab.

Next Lesson: Lesson 6: Display and Reposition a Ribbon Tab on page 18

Lesson 6: Display and Reposition a Ribbon Tab

Display and reposition My Utilities tab on the ribbon
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In this lesson, you will help John Cad and Partners to display and reposition
a ribbon tab on the ribbon.

You use the Workspace Contents pane of the CUI Editor to add and remove
ribbon tabs from the ribbon, which is controlled by the current workspace.
Once a ribbon tab has been added to a workspace, you can control the order
in which the tab is displayed on the ribbon.

To display or hide a ribbon tab

1 On the ribbon, click the Tools tab ➤ Customization panel ➤ User

Interface. 

2 In the Customizations In All CUI Files pane, next to Workspaces, click
the plus sign (+) and click 2D Drafting & Annotation Default.

3 In the Workspace Contents pane, click Customize Workspace.

4 In the Workspace Contents pane, next to the Ribbon Tabs, click the plus
sign (+).

5 In the Customizations In All CUI Files pane, next to Ribbon Tabs, click
the plus sign (+). Clear the Annotate option.
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The Annotate ribbon tab is now removed from the Ribbon Tabs node in
the Workspace Contents pane.

NOTE To redisplay the Annotate tab on the ribbon, click the Annotate in the
Ribbon Tabs list in the Customizations in All CUI Files pane.

6 Ensure that My Utilities option is selected.

7 Click Apply.

To reposition a ribbon tab on the ribbon

8 In the Workspace Contents pane, drag My Utilities under the Home - 2D
tab. To specify the position of the ribbon tab on the ribbon, use the visual
indicator.

9 In the Workspace Contents pane, click Done.

10 Click OK.
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11 On the ribbon, click the My Utilities tab ➤ My Tools panel. Click the
panel's title bar to expand the panel.

The ribbon after it has been customized

Summary: In this lesson, you learned how to display and reposition a ribbon
tab.

Congratulations! You have helped John Cad and Partners to customize the
ribbon to display their frequently used commands on a custom ribbon panel
and tab.
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